Go Back   SUPERNISSANS.NET Nissan Owners Community > SUPERNISSANS COMMUNITY > Nissan Altima Technical Discussion
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-19-2017, 06:54 AM
Honda Sucks
 
Join Date: Dec 2001
Location: Sharon, PA
Posts: 1,248
wild willy is just really nicewild willy is just really nicewild willy is just really nicewild willy is just really nice
Default Code-PO101 MAF

Code-PO101 MAF
So yesterday, at approximately 47,000 miles my check engine light came on. No drivability issues, no symptoms...nothing. So I run it home and read the code with turned out to be MAF. I cleaned it, changed the air filter, cleaned out the box and cleared the code. Light has not come back on, but I have not driven many miles at all. After doing some research, I found a TSB on the issue NTB-12-051D. I guess my question is....should the light return, will the dealer perform the TSB free of charge? Is the MAF part of the Emissions warranty and covered?? I hate to take my car to the dealer, but if it is covered..I will and cross my fingers that they do not F anything else up. How long does it typically take for the code to reappear if the MAF is actually faulty or there is a potential vacuum leak?

Thanks,

Bill

PS- T have had a 3.5 Altima since October of 2001....this is the first malfunction I have ever had.....not too shabby
__________________
12 Altima SR
12 Quest SL
91 MR2
04 Honda Oddy (POS)-GONE!!
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #2 (permalink)  
Old 10-22-2017, 02:04 PM
Sassan's Avatar
Admin
 
Join Date: Sep 2000
Location: Columbus
Posts: 10,322
Sassan is a name known to allSassan is a name known to allSassan is a name known to allSassan is a name known to allSassan is a name known to allSassan is a name known to all
Send a message via AIM to Sassan
Default

It also only has 47k miles on it after 16 years.....i am guessing "dirty" sensor.
__________________
Supernissans.net Founder.
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
  #3 (permalink)  
Old 10-22-2017, 02:18 PM
Honda Sucks
 
Join Date: Dec 2001
Location: Sharon, PA
Posts: 1,248
wild willy is just really nicewild willy is just really nicewild willy is just really nicewild willy is just really nice
Default

Quote:
Originally Posted by Sassan View Post
It also only has 47k miles on it after 16 years.....i am guessing "dirty" sensor.
Sensor was pretty clean.....Filter was another story. It is running like a bat out of hell now.....It a 2012...so not that old
Digg this Post!Add Post to del.icio.usBookmark Post in TechnoratiFurl this Post!
Reply With Quote
Reply

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



New To Site? Need Help?

All times are GMT -4. The time now is 10:57 AM.

Forum Stats
Members: 9,402
Threads: 9,378
Posts: 113,639

Newest Member: FTP187
Latest Threads
Forum Sponsors
Contact us to be here
Forum Partners

Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
DTO Garage vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Friendly URLs by vBSEO 3.1.0